The Matrix Online Server Emulator
The file client.dll could not be setup properly. - Printable Version

+- The Matrix Online Server Emulator (http://mxoemu.info/forum)
+-- Forum: The Matrix Online (http://mxoemu.info/forum/forumdisplay.php?fid=3)
+--- Forum: The MxO Client (http://mxoemu.info/forum/forumdisplay.php?fid=7)
+--- Thread: The file client.dll could not be setup properly. (/showthread.php?tid=2013)



The file client.dll could not be setup properly. - Blackarachnid - 24-10-2014

As the subject addresses, I am unable to get past the 'Create' button on the launcher when you're confronted with the server list.

I have tried every possible compatibility combination, and nothing works.

My graphics card is relatively old, and it's a Radeon, which MxO was primarily built to function on, so I'm pretty sure that isn't it.

Do you guys have a fix? Please and thank you!

PS: See attachments for deets and helpful info <3


RE: The file client.dll could not be setup properly. - bitbomb - 24-10-2014

Character creation is done on the website, in-game character creation does not work as is stated in the FAQ. Click 'Register' at the top left of mxoemu.info and definitely read the FAQ before proceeding. The link is in my signature.


RE: The file client.dll could not be setup properly. - rajkosto - 26-10-2014

Your CPU, OS, GPU are all fine for MxO, I'd like to see what's actually the problem so I've PM'd you.


RE: The file client.dll could not be setup properly. - slicksilverman - 06-11-2016

I'm also having this issue... But I've created a couple characters on the website and still having the issue...

What else could cause this issue?


RE: The file client.dll could not be setup properly. - rajkosto - 06-11-2016

Do you have a graphics card ?


RE: The file client.dll could not be setup properly. - slicksilverman - 06-11-2016

Intel GMX 3100 chip on board. Obviously not a new computer but better graphics capability than the computer I was running the program on years ago.


RE: The file client.dll could not be setup properly. - rajkosto - 08-11-2016

So, that's a no. It needs to have PS and VS 3.0, i think that one doesn't have either. Or just maybe needs proper drivers ?
"GMA X3000/X3100 on Windows: T&L and Vertex Shaders 3.0 are supported by Intel's newest 15.6 drivers for Windows Vista as of September 2, 2007."