The Matrix Online Server Emulator
Patcher won't update - Printable Version

+- The Matrix Online Server Emulator (http://mxoemu.info/forum)
+-- Forum: Documentation (http://mxoemu.info/forum/forumdisplay.php?fid=8)
+--- Forum: Client Side (http://mxoemu.info/forum/forumdisplay.php?fid=9)
+--- Thread: Patcher won't update (/showthread.php?tid=2419)

Pages: 1 2


Patcher won't update - Beestly - 19-11-2018

Hey guys. I've checked out all the instructions I could find, and can't find any answers for this problem. I've seen people mention it, but no resolution.

I created an account on the main site, created my character, downloaded the MatrixOnline.7z and the 7.6003p_patcher.zip files, extracted them, overwrote any existing files (renamed them to .old), and started it up, with no success. The launcher will open, but it will give me the error no matter if I check the toggle for "Patch: Full System Check" or not. I've run as admin, as well. Disabled any firewall / antivirus apps..

The launcher gives me the error popup:

Patch system error (result code -47)
URL open failed. Patch servers down or Internet Connection problem.

Then in the launcher itself, it shows: Received unexpected result code from patcher (0).

Anyone have any ideas? I had no idea this emu was in existence at all, and I absolutely LOVED MxO from beta testing it, forward. I got a bit giddy to even be able to jump around like we used to, just to have it destroyed when I can't get past the launcher. I'm fairly well-versed in general computer stuff, just not into coding or anything particularly useful, so please feel free to get technical in your response if needed; I should be able to follow just fine.

Thanks, and hope to see some of you in game!


RE: Patcher won't update - Beestly - 19-11-2018

(19-11-2018, 03:13 AM)Beestly Wrote: Hey guys. I've checked out all the instructions I could find, and can't find any answers for this problem. I've seen people mention it, but no resolution.

I created an account on the main site, created my character, downloaded the MatrixOnline.7z and the 7.6003p_patcher.zip files, extracted them, overwrote any existing files (renamed them to .old), and started it up, with no success. The launcher will open, but it will give me the error no matter if I check the toggle for "Patch: Full System Check" or not. I've run as admin, as well. Disabled any firewall / antivirus apps..

The launcher gives me the error popup:

Patch system error (result code -47)
URL open failed. Patch servers down or Internet Connection problem.

Then in the launcher itself, it shows: Received unexpected result code from patcher (0).

Anyone have any ideas? I had no idea this emu was in existence at all, and I absolutely LOVED MxO from beta testing it, forward. I got a bit giddy to even be able to jump around like we used to, just to have it destroyed when I can't get past the launcher. I'm fairly well-versed in general computer stuff, just not into coding or anything particularly useful, so please feel free to get technical in your response if needed; I should be able to follow just fine.

Thanks, and hope to see some of you in game!

Uhhh, well, somehow, I just fixed it..? I'll go through the exact steps. Not sure how this worked, as everything is the same, essentially..

1. Removed the files from the 7.6003p_patcher.zip, and restored the old ones. Ran launcher again, no success.

2. Moved the install dir from my desktop to directly on C Drive. Ran again, no success.

3. Restarted PC, disabled Peerblock, and ESET smart security firewall and protection (just to be sure), as I had done previously. Double checked settings to be sure firewall was off, as it has caused issues in the past. Check.

4. Copied the files back over from 7.6003p_patcher.zip, ran it again. SUCCESS!

The only thing I can think of that happened differently, was the fact I didn't ensure my firewall was fully off the first time. I typically disable it from the tray icon instead of loading the app fully and doing it that way. The first time, I used the tray icon and didn't open the app to confirm it was truly off.

Very weird. Almost certain it has to be ESET Smart Security's firewall that was blocking access to the patch server, so either add an exclusion for it, or disable the firewall completely..

Of course, the success comes right after I finish downloading the MxOEmu Easy Setup from seattlescape..


RE: Patcher won't update - pr0sper0 - 19-11-2018

Glad things worked out for you to crack this nut on your own. Thanks for posting the steps here; I'm sure this is going to help someone else in the future.


RE: Patcher won't update - Beestly - 19-11-2018

(19-11-2018, 06:56 AM)pr0sper0 Wrote: Glad things worked out for you to crack this nut on your own. Thanks for posting the steps here; I'm sure this is going to help someone else in the future.

Thanks man, I definitely appreciate it. Glad to post the steps as well, in hopes of helping someone else in the future.

I did get in game and mess around a bit, and it was so much fun. Brought back so many memories, lol. It does make me wish that we had a fully-functional game to mess around in, but what's been done already is a pretty amazing feat. I'll swap over to general discussion or somewhere relevant to continue fantasizing about the return of the full game..


RE: Patcher won't update - Batblade123 - 22-08-2019

I need help I tried this but the launcher gives me the error popup:

Patch system error (result code -47)
URL open failed. Patch servers down or Internet Connection problem.

Then in the launcher itself, it shows: Received unexpected result code from patcher (0).


RE: Patcher won't update - bitbomb - 22-08-2019

What steps have you done so far? You've unzipped the game archive to a directory somewhere (I use d:\mxo), and unzipped the patcher into the game directory? And you're running 'launcher.exe?'


RE: Patcher won't update - Batblade123 - 22-08-2019

Yes, I ran the launcher.exe


RE: Patcher won't update - Batblade123 - 22-08-2019

(22-08-2019, 07:52 PM)bitbomb Wrote: What steps have you done so far? You've unzipped the game archive to a directory somewhere (I use d:\mxo), and unzipped the patcher into the game directory? And you're running 'launcher.exe?'

Is there something I'm doing wrong and is it possible if you can give me a step by step on how to do it?


RE: Patcher won't update - Batblade123 - 22-08-2019

its up and running now


RE: Patcher won't update - Synapze777 - 21-09-2019

Im having problems patching too